Belfius Open Banking - Payment Service - Degraded performance

Incident Report for Tink providers Belgium

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jul 03, 2025 - 06:52 UTC

Investigating

We are currently investigating an issue with Belfius.

The payment service is affected by a degraded performance. Only about 30% of all initiations are successful.
Posted Jun 30, 2025 - 11:02 UTC
This incident affected: Belfius.