Crelan - Degraded Performance
Incident Report for Tink providers Belgium
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Dec 27, 2022 - 08:57 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 19, 2022 - 09:31 UTC
Identified
We have identified the issue and are in contact with Crelan for further information.
We will update when a significant change to the situation occurs.
Posted Nov 09, 2022 - 19:39 UTC
This incident affected: Crelan.