Revolut - Open Banking issue

Incident Report for Tink providers Belgium

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 09:13 CEST

Investigating

We are currently investigating an issue with Revolut
- Affected users:  70%
- Affected flow:  Account Information Service flow
- Start Time:  21/08/2026 [6:00] CET
- Bank side error: increase of failed refreshes
- Provider name:  be-revolut-ob
Posted Aug 21, 2026 - 09:10 CEST
This incident affected: Revolut.