Keytrade Open Banking - Degraded performance affecting Account Information
Incident Report for Tink providers Belgium
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Nov 11, 2024 - 16:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 11, 2024 - 13:45 UTC
Identified
We have identified the issue and we will update when a significant change to the situation occurs.
Posted Nov 11, 2024 - 09:27 UTC
This incident affected: Keytrade Bank.