CPH - Major Outage

Incident Report for Tink providers Belgium

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2025 - 08:26 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Feb 10, 2025 - 06:55 UTC
This incident affects: CPH.