KBC Open banking - Degraded performance
Incident Report for Tink providers Belgium
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 03, 2024 - 12:39 UTC
Investigating
We are currently investigating an issue with KBC.
Posted Apr 02, 2024 - 18:53 UTC
This incident affected: KBC/CBC.