Belfius - Major Outage
Incident Report for Tink providers Belgium
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Nov 13, 2024 - 13:56 UTC
Investigating
We are currently investigating an issue with Belfius that started around 11:22 CET.
Posted Nov 13, 2024 - 10:32 UTC
This incident affected: Belfius.