Nagelmackers Open banking Background refresh - Major outage
Incident Report for Tink providers Belgium
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 13:19 UTC
Update
We are continuing to investigate this issue.
Posted Feb 01, 2024 - 10:16 UTC
Investigating
We are currently investigating an issue with Nagelmackers .
Posted Feb 01, 2024 - 09:56 UTC
This incident affected: Nagelmackers.