Keytrade Bank Outage

Incident Report for Tink providers Belgium

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Mar 25, 2026 - 12:44 CET

Investigating

We are currently investigating an issue with Keytrade Bank.

- Affected users: 100%
- Affected flow: Manual authentication | Refresh authentication
- Start Time: [24/03/2026] [12:30] CET
- Bank side error: 500 HTTP resposnes
- Provider name: be-keytradebank-ob
Posted Mar 24, 2026 - 12:57 CET
This incident affected: Keytrade Bank.