Belfius Open Banking - Background refresh Degraded performance
Incident Report for Tink providers Belgium
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Apr 21, 2024 - 15:45 UTC
Investigating
We are currently investigating an issue with Belfius.
Posted Apr 20, 2024 - 12:45 UTC
This incident affected: Belfius.