Crelan - Major outage

Incident Report for Tink providers Belgium

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted May 10, 2026 - 18:32 CEST

Investigating

We are currently investigating an issue with Crelan.
- Affected users: 100%
- Affected flow: Manual authentication | Refresh authentication | Payment Initiation flow
- Start Time: 10/05/2026 05:00 CET
- Bank side error: 5xx error
- Provider name: be-crelan-ob
Posted May 10, 2026 - 07:25 CEST
This incident affected: Crelan.