BNP Paribas Fortis Open Banking - Payment Initiation services Degraded performance

Incident Report for Tink providers Belgium

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 05, 2025 - 09:06 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jun 04, 2025 - 09:20 UTC
This incident affected: BNP Paribas Fortis.